Service Disruption: Adding Funds and Payment Methods

Incident Report for Keen Status

Resolved

We have rolled back the change that was causing the issue with our third-party provider. Site functionality—including adding funds and viewing payment methods—has been fully restored.

Thank you for your patience while we worked to resolve this. If you continue to experience any issues, please reach out to our support team.
Posted Jun 22, 2026 - 14:58 PDT

Investigating

We are currently experiencing an issue with one of our third-party payment providers. As a result, some customers may experience errors when attempting to add funds or view their saved payment methods.

Our team is actively monitoring the situation and working with the provider to resolve this as quickly as possible. We appreciate your patience and will provide updates here as we learn more.
Posted Jun 22, 2026 - 14:43 PDT