Scheduled Maintenance

Incident Report for Keen Status

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 13:07 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 16, 2025 - 12:40 PDT

Identified

Keen will be undergoing scheduled maintenance this Thursday, 7/17, from 1:00 a.m. to 2:00 a.m. PST (overnight from Wednesday). Please note that the site will be completely unavailable during this time. We appreciate your patience and understanding!
Posted Jul 16, 2025 - 12:39 PDT