Investigating: Intermittent Pages Loading and 404 Errors

Incident Report for Keen Status

Resolved

The issues causing intermittent page loading delays and 404 errors have been fully resolved.

Our engineering team quickly identified a minor misconfiguration and corrected it. The brief disruption lasted for less than 5 minutes, and all systems are now back to operating normally at 100% capacity.

Thank you so much for your patience.
Posted Jun 24, 2026 - 13:57 PDT

Identified

We are currently investigating reports of intermittent issues across our platform. Some users may experience slow page loading times or encounter 404 error pages when trying to access certain sections of the site.

Our engineering teams are actively looking into the root cause to resolve this as quickly as possible. We sincerely apologize for the disruption and will provide another update as soon as we have more information.
Posted Jun 24, 2026 - 12:46 PDT