Service Disruption: Calls dropping or not connecting

Incident Report for Keen Status

Resolved

We’ve mitigated the issue and are continuing to investigate the root cause. Please let us know if you continue to experience any issues, and we’ll be happy to look into it further.
Posted Apr 01, 2026 - 09:47 PDT

Identified

Our technical team is actively investigating the root cause of an issue causing some calls to drop or fail to connect, accompanied by the message: “We’re sorry, an application error has occurred.”

We’re working to implement a fix as quickly as possible and will share updates as they become available.
Posted Apr 01, 2026 - 09:37 PDT