Advisor App Update Issue

Incident Report for Keen Status

Resolved

This incident has been resolved.
Posted Aug 22, 2026 - 15:28 PDT

Investigating

We are currently aware of an issue with the Advisor App redirecting to the Consumer App. Please use the Advisor Dashboard on the web in the interim. Thank you for your understanding.
Posted Aug 22, 2026 - 14:58 PDT