Apple Pay is currently down for Web users at the moment, and we're actively working on resolving this

Incident Report for Keen Status

Resolved

This incident with Apple Pay on the website has been resolved.
Posted Aug 13, 2026 - 13:28 PDT

Investigating

We are currently investigating this issue.
Posted Aug 13, 2026 - 13:05 PDT