Service Disruption

Incident Report for Keen Status

Resolved

All systems are back up and running! Thank you for your patience during this brief outage, and we apologize for any disruption to your workflow. 🛠️
Posted Jul 13, 2026 - 09:30 PDT

Investigating

We are currently experiencing a brief outage, and are investigating this currently.

We sincerely apologize for any frustration or disruption this may have caused to your workflow. Thank you for your patience while we worked to get things back up and running! 🛠️
Posted Jul 13, 2026 - 08:48 PDT