Investigating: Site Performance Issues

Incident Report for Keen Status

Resolved

The issues causing site errors and slowness during our recent update deployment have been fully resolved. All systems are operational, and the platform is performing normally. Thank you for your patience!
Posted Jul 20, 2026 - 10:15 PDT

Identified

We are currently deploying a scheduled update and are experiencing unexpected site errors and slowness. Our team is actively investigating the root cause and working to restore full functionality as quickly as possible. We apologize for the disruption!
Posted Jul 20, 2026 - 09:51 PDT